网站首页 > pcfcms大学 > pcfcms安全

阿里云主机
PCFCMS下载
点击下载

ThinkPHP5 核心类Request远程代码执行高危漏洞

来源:大福 发布时间:2020-07-29 09:21:35 热度:

2019年1月11日,阿里云云盾应急响应中心监测到ThinkPHP官方发布安全更新,披露了一个高危安全漏洞,攻击者构造特定的恶意请求,可以直接获取服务器权限,受影响的版本包括5.0.0~5.0.23版本及5.1多个版本。

CVE
披露时间
2019年1月11日 18:00:32
CVSS
危险等级
严重
漏洞特征
远程代码执行
详情
由于ThinkPHP5框架对Request类的method处理存在缺陷,导致黑客构造特定的请求,可直接GetWebShell。 影响版本 ThinkPHP 5.0系列 < 5.0.24 ThinkPHP 5.1多个版本 安全版本 ThinkPHP 5.0系列 5.0.24
修复建议

升级至安全版本5.0.24